Name is required.
Email address is required.
Invalid email address
Answer is required.
Exceeding max length of 5KB

Fitbit not syncing with MyFitnesspal neel3013 — Oct 24, 2016 04:54PM PDT

Myfitness pal stop syncing with my fitbit. I have revoked access and relinked. No luck. Please help

6 Community Answers

Up 1 rated Down

Logan MyFitnessPal Agent Oct 24, 2016 04:56PM PDT

Hey thanks for posting your question. Sorry for the trouble with your fitbit integration. When we view the account we are seeing that the accounts have been relinked today, however, fitbit has not been selected as the source for step tracking. Please open the Menu, select Steps, and click on fitbit to make it your source for step tracking. Then log a few hundred new steps with your tracker, and initiate a manual sync in fitbit, followed by another in MyFitnessPal. Please follow up with us if you are still not seeing your data making it over within 24 hours of reselecting it as your source.

Kind regards,
Logan
MyFitnessPal Staff


Up 0 rated Down

CindyPong101 Oct 31, 2016 07:37PM PDT

Hi

Not sure if I'm posting at the right place, I am encountering the same problem.

My fitness pal stopped syncing with my fitbit after the recent update, I've tried to close app and open app again, I've also tried to switch off my phone but still no luck.

I'm using IOS 10.1

Please help!


Up 0 rated Down

hkchub Nov 01, 2016 08:55AM PDT

I have the exact same problem. I've checked, relink, and set the step tracker to fitbit. Nothing happened! It stopped syncing since Oct 19. Please help!


Up 0 rated Down

Logan MyFitnessPal Agent Nov 01, 2016 10:13AM PDT

CindyPong101

Thanks for posting. Sorry for the trouble with your fitbit untegration. Would you please try disconnecting and relinking your accounts to see if a fresh link resolves your issue? Once reconnected, please remember to revisit the Steps tab and reselect fitbit as your primary step source.

hkchub
When we look at your account status we are showing your fitbit as having been linked since November of last year. Please try relinking and reselecting your step source one more time. This time please try selecting Do Not track Steps and logging out of the MyFitnessPal app, before revoking access to MyFitnessPal on the fitbit webste and then relink the account at www.myfitnesspal.com.

Warm Regards,
Logan
MyFitnessPal Staff


Up 0 rated Down

bonniebyork Nov 02, 2016 10:00AM PDT

I have tried all of the above suggestions and am still unable to sync my steps from my Flex. I have forced the apps to stop, linked and unlinked, and tried everything that I have seen online to get MFP to relink my steps. Do I have to find another app to use or buy a new tracker?


Up 0 rated Down

Logan MyFitnessPal Agent Nov 02, 2016 10:44AM PDT

bonniebyork

Thanks for following up with us. Sorry for the trouble. If you have already unlinked the accounts our website, www.myfitnesspal.com, revoked access at fitbit.com, waited 15 minutes, relinked the accounts on our site, and reselected fitbit as you step source, please check the APP/Play Store to make sure that you are running the latest version of both apps.

If everything is up to date, would you please also let us know what model device you are using, which version of it’s operating system that it is running, and which version of the MFP app is currently installed? You may find the app version by opening the Menu, selecting Help, followed by About Us.

Warm Regards,
Logan
MyFitnessPal Staff


Contact Us

Don't see the answer to your question?

Your fellow MyFitnessPal users and our Customer Happiness Team are always here to help.