Name is required.
Email address is required.
Invalid email address
Answer is required.
Exceeding max length of 5KB

MFP/Fit Bit Blaze not sycing OliviaMarie27 — Jan 11, 2017 11:13AM PST


I have been trying to integrate my fit bit with myfitnesspal for two weeks now.

Here is what I have tried:
-Signing in Signing out from both accounts.
-Uninstalling and reinstalling both applications from my phone.
-Signing in and signing out on a computer on both programs.
-Setting it up only in my phone.
-Setting it up only via the computer.
-Revoking and allowing privileges from both ends. Multiple times waiting days for it to go unconnected to connected to ensure enough time.
- I have also tried to manually "push" syncing while updating.

I've already contacted Fitbit and they have given me the clear on their end that everything is set up right.

Seeing how this is an apparent issue with MFP, I'd hope you'd have a fast way to resolve it.

2 Community Answers

Up 0 rated Down

kpolka Jan 11, 2017 11:28AM PST

I'm wondering what's up too. I signed up just three days ago and love MFP so much that I really want to spring for Premium -- BUT, it took me all day and several tries of going through every suggestion here in the help pages. Step-by-step. Finally it started working that night. Great! Until...

Today its hung up at 55 steps. It's writing my food to fitbit tracker...but my steps are not in MFP. Frustrating.

Also convinced my sister this was the best app ever and to try this before springing for WW. She signed up this morning. Unable to synch steps.

Should I give up?

Up 0 rated Down

Logan MyFitnessPal Agent Jan 11, 2017 12:29PM PST


Hey thanks for posting your question. Sorry for the trouble with your fitbit integration. When we view the account we are seeing that the accounts have been relinked recently, however, fitbit has not been selected as the source for step tracking. Please open the Menu, select Steps, and click on fitbit to make it your source for step tracking. Then log a few hundred new steps with your tracker, and initiate a manual sync in fitbit, followed by another in MyFitnessPal.


Please try initiating a manual sync from both apps, stating with fitbit. Then click Sync at the bottom of the Menu screen in MyFitnessPal. As a fitbit user myself, I find that I occasionally have to do this to see my up to date numbers.

If you are still experiencing an issue after forcing a sync manually, please try unlinking the accounts at, then revoking access on, waiting 15 minutes, and then relinking them on our site. Keep in mind that only new information, completed after they are reconnected will sync.

Steps to revoke access:
1. Log into
2. Click the Settings Icon (Looks like a gear) and choose “Settings”.
3. On the left side, click the Applications tab and locate MyFitnessPal
4. The option to “Revoke Access” will show in blue if your account is still linked.
5. Wait 15 minutes before attempting to relink the accounts.
6. Return to and reconnect the accounts in the Apps tab

Please remember to revisit the step tab in our app’s Menu to reset fitbit as your source for step tracking.

Kind regards,
MyFitnessPal Staff

Contact Us

Don't see the answer to your question?

Your fellow MyFitnessPal users and our Customer Happiness Team are always here to help.