Name is required.
Email address is required.
Invalid email address
Answer is required.
Exceeding max length of 5KB

Samsung Health not syncing calories anabasso — Jun 07, 2018 02:15AM PDT

I am using a Galaxy S8 and a Gear Sport. I linked MFP and S Health and authorized all read and write permissions on the mobile app.
I have the Gear app installed as well, but it logs in automatically and doesn't request for permissions (I already tried to uninstall it install it back again).

I use S Health to track exercises and steps (calories burned) and MFP to track food intake (calories consumed).
I can see the calories burned on MFP, but I can't see the calories consumed on the S Health. What am I missing?
I tried installing, disconnecting both apps and reconnecting, giving only specific permissions or authorizing all read and write permissions, but nothing seems to work.

Thanks in advance

2 Community Answers

Up 0 rated Down

Bruce MyFitnessPal Agent Jun 07, 2018 07:05AM PDT

Hi there,

Thank you for taking the time to contact us. You will need to allow for all permissions in order for the integration to work. Can you try relinking S Health once more and see if that will help?

To get started, under the Menu Bar tap Apps & Devices and tap Connected. Select S Health and tap Disconnect. Once the page updates, tap Connect. You should see a pop up for permissions regarding the Samsung Health integration. Turn the integration On and then allow the permissions. Please note you will need to scroll down on this pop up to see all of the permissions. Tap Done to finish the set up.

Next, return to the Menu Bar in MyFitnessPal and tap Steps>Samsung Health.

Hope this helps. Please let me know if you have any other questions or feedback.

All the best,
Bruce
MyFitnessPal


Up 0 rated Down

anabasso Jun 07, 2018 07:36AM PDT

Hey Bruce, I followed those steps again a few times and it didn't work.

I solved the problem by doing this:

After following your instructions to disconnect and re-connect the apps.
On Steps in MFP, Samsung Health was already connected for me.
So I chose "don't track steps" and, after loading, re-selected Samsung Health. I believe that forced both apps to re-connect.

After that, syncing started working in both ways.

I hope this post helps whoever has the same problem :)


Contact Us

Don't see the answer to your question?

Your fellow MyFitnessPal users and our Customer Happiness Team are always here to help.