Name is required.
Email address is required.
Invalid email address
Answer is required.
Exceeding max length of 5KB

Fitbit still not syncing to MFP catherinebromberg — Mar 17, 2017 07:01AM PDT

Hello - I've selected the Fitbit App, tried to connect it to my MFP account, no success. I have two (2) trackers (Flex 2 and One) that both sync to my Fitbit account, depending on which I'm wearing, but nothing is showing up here. Help?

3 Community Answers

Up 0 rated Down

Ripley MyFitnessPal Agent Mar 17, 2017 12:39PM PDT

Hello catherinebromberg,

Thank you for taking the time to post your question.

Your account is showing on MyFitnessPal as having an expired access token, meaning Fitbit has revoked access.

However, it should be easy to fix if you follow the exact steps outlined below.

First, log into your Fitbit account, click the gear icon and choose “settings”.

Once inside the settings, click the Applications tab and locate MyFitnessPal. Once you find MyFitnessPal click “revoke” access.

Once you revoke access on Fitbit you will need to go back to MyFitnessPal and relink.

Additionally, once relinked please make sure you have Fitbit chosen as your primary step source within the MyFitnessPal app, which could be causing the adjustment not to come through. Would you please select Steps from the app menu and choose Fitbit as your primary step source.

Hope this helps! We wish you the best of luck in meeting and maintaining all your fitness goals!

Best,

Ripley
MyFitnessPal Staff


Up 0 rated Down

leonardi71 Mar 21, 2017 08:45AM PDT

i have been having the same issue. i followed these steps with no success. anything else i should try?


Up 0 rated Down

Blake MyFitnessPal Agent Mar 21, 2017 09:32AM PDT

leonardi71,

What happened when you attempted to set Fitbit as your primary step source?

Blake
MyFitnessPal Staff


Contact Us

Don't see the answer to your question?

Your fellow MyFitnessPal users and our Customer Happiness Team are always here to help.