Name is required.
Email address is required.
Invalid email address
Answer is required.
Exceeding max length of 5KB

Fitbit xmas_carroll — Apr 17, 2017 09:52AM PDT

My steps aren't showing up in my Diary. I have it synced and it shows but it doesn't show my steps. How can I fix this?

Thanks!

6 Community Answers

Up 0 rated Down

Logan MyFitnessPal Agent Apr 17, 2017 10:32AM PDT

Thanks for posting and sorry for any trouble with your fitbit integration. We’re currently investigating the issue which has caused steps from fitbit to stop syncing around Saturday 4/15. Would you mind following the sync from your tracker to see where the communication breakdown is occurring? Please check to see if your tracker is consistently updating your fitbit app, then log into your account at fitbit.com to confirm that it has reached their site, followed by logging into your account at www.myfitnesspal.com to see if it’s reached ours. We know it’s not reaching our app but it would be good to know if it’s between our app and site or between the 2 websites.

Warm Regards,
Logan
MyFitnessPal Staff


Up 0 rated Down

lynnefp17 Apr 17, 2017 01:42PM PDT

I'm having the same problem...it stopped syncing on Saturday 4/15. I have re-installed the apps for each Fitbit and MFP. I spoke with Fitbit this AM and the problem does not seem to be with them.


Up 0 rated Down

Logan MyFitnessPal Agent Apr 17, 2017 01:54PM PDT

Thanks for following up with us.

The fitbit integration should now be recovering. While there will be a backlog of sync requests to work through, things should slowly be getting back to normal in a few hours.

Warm Regards,
Logan
MyFitnessPal Staff


Up 0 rated Down

marablanger Apr 19, 2017 05:46PM PDT

Hi I am having the same issue. I have disconnected and reconnect Fitbit and MFP several times and no luck. I have waited in between and it still doesn't work.

Now I just tried to re-install the Fitbit app on your website, and it's giving me an error.

Please advise.
-Mara


Up 0 rated Down

Logan MyFitnessPal Agent Apr 20, 2017 10:18AM PDT

marablanger

Thanks for posting and sorry for any trouble. It sounds as if you may have run into a problem with your access token (basically, the data required to get past the toll booth to cross the bridge from one partner to the other). To refresh your token, please perform the following exact steps:

- Go to our main website at www.MyFitnessPal.com, then to the Apps tab, then check to see if fitbit is showing as Connected under your apps. If so please Disconnect it.
- Then log into your Fitbit account at www.fitbit.com, click the gear icon, then Settings, next click Applications. If MyFitnessPal is showing as Connected there, click the blue ‘Revoke Access’ button and revoke access for MyFitnessPal
- It’s important to make sure Fitbit has been disconnected on both MyFitnessPal and Fitbit
- Once disconnected, please wait 15 minutes then try to reconnect from the MyFitnessPal website
- Go back to www.MyFitnessPal.com website (not the Fitbit or MFP app) and relink your Fitbit device via the main Apps tab, here.
- Once you have reconnected, go back to the Apps tab online and make sure Fitbit is now showing on the right-hand side of the page under Your Apps

This should refresh your link on both sides. Once you have reestablished the connection, you need to then make sure to elect Fitbit as your step source.

You can elect Fitibit as your Step source either via the Menu in the App, then Steps. Or online here.

Warm Regards,
Logan
MyFitnessPal Staff


Up 0 rated Down

sfine3526 Apr 28, 2017 01:08PM PDT

Thanks Logan for your detailed instructions. I have been having issues for weeks and finally today I tried again step by step on my computer instead of phone and... it worked! :)


Contact Us

Don't see the answer to your question?

Your fellow MyFitnessPal users and our Customer Happiness Team are always here to help.