Name is required.
Email address is required.
Invalid email address
Answer is required.
Exceeding max length of 5KB

MFP syncs with Apple iPhone steps but not Fitbit SRD2012 — Sep 07, 2017 08:41AM PDT

When I toggle to my iPhone for recording steps, it reads them just fine. But not when I switch back to FitBit. I leave my phone stationary on the treadmill when I run, so FitBit is far more accurate. I'm not sure it matters in the end, but it would be nice if it worked as promised. Thank you!

1 Community Answers

Up 0 rated Down

Logan MyFitnessPal Agent Sep 07, 2017 09:50AM PDT

Thanks for posting and sorry for any trouble. Please try selecting Don’t track steps, then force quitting the app, and power cycling your phone. Then boot it back up, open the app and reselect Fitbit a your source for step tracking. Log a few hundred new steps and then manually initiate a sync in fibtit, followed by another in MyFitnessPal.

Warm Regards,
Logan
MyFitnessPal Staff

Contact Us

Don't see the answer to your question?

Your fellow MyFitnessPal users and our Customer Happiness Team are always here to help.