Name is required.
Email address is required.
Invalid email address
Answer is required.
Exceeding max length of 5KB

FitBit Alta ScarletColette — Jun 20, 2018 06:28PM PDT

Hello,
I'm unable to sync my new fitbit Alta with MFP. My devices say the accounts are linked and have access, but no steps appear. I just received this fitbit on 6/9 and haven't been able to sync them.

3 Community Answers

Up 0 rated Down

Bruce MyFitnessPal Agent Jun 21, 2018 08:38AM PDT

Hi there,

We have refreshed the Fitbit connection from our end. Can you revoke access from Fitbit’s end and see if that will help? To do this, log in at www.fitbit.com and click the gear icon, then Settings>Applications. Click Revoke Access for MyFitnessPal.

This should refresh your link on both sides, instead of just one. You can then link them again at https://www.myfitnesspal.com/apps/show/30.

Once relinked, please be sure to set Fitbit as the Steps source once again.

Please let us know if you see any changes.

All the best,
Bruce
MyFitnessPal


Up 0 rated Down

fawn_eyes888 Jul 18, 2018 07:40AM PDT

I also have the same issue. I tried the above fix and it says its connected already, it does not see to have refreshed the settings at all and it is still not logging steps. Please advise.


Up 0 rated Down

Bruce MyFitnessPal Agent Jul 18, 2018 07:55AM PDT

Hi fawn_eyes888

Would you please provide your fitbit ID# so we may try a search with that on our end? You are welcome to provide your ID# here, keep in mind that it is a public forum, however, if you would prefer to share it privately, please click here to reach us via email instead.

Steps to get user ID#
1. Log in at http://www.fitbit.com and click on your profile photo.
2. This will take you to your Fitbit.com Profile and now copy the URL from your browser’s address field and paste it in the email reply

Your fitbit ID will look something like this: www.fitbit.com/user/1234A

Kind regards,
Bruce
MyFitnessPal


Contact Us

Don't see the answer to your question?

Your fellow MyFitnessPal users and our Customer Happiness Team are always here to help.